Lux Aliaga
dd8dfccb1f
pmbootstrap doesn't consider underscores as part of codenames, so we'll rename the device package to "laurel" instead of "laurel_sprout". Kernel DTBs will keep the actual device name, since (at least from my knowledge) it's accepted.
30 lines
609 B
Plaintext
30 lines
609 B
Plaintext
# Reference: <https://postmarketos.org/devicepkg>
|
|
pkgname=device-xiaomi-laurel
|
|
pkgdesc="Xiaomi Mi A3"
|
|
pkgver=0.1
|
|
pkgrel=3
|
|
url="https://postmarketos.org"
|
|
license="MIT"
|
|
arch="aarch64"
|
|
options="!check !archcheck"
|
|
depends="
|
|
linux-postmarketos-qcom-sm6125
|
|
mesa-dri-gallium
|
|
mkbootimg
|
|
postmarketos-base
|
|
"
|
|
makedepends="devicepkg-dev"
|
|
source="deviceinfo"
|
|
|
|
build() {
|
|
devicepkg_build $startdir $pkgname
|
|
}
|
|
|
|
package() {
|
|
devicepkg_package $startdir $pkgname
|
|
}
|
|
|
|
sha512sums="
|
|
1f0183d38e8f169319b6bdd49948a8368227d7e6d7c68df6c288ca241b70c73cd4efd16f4b518a8288ef3e3a6874b8ffd4ce1a4527ed7a531f26d7a59fe4e4c1 deviceinfo
|
|
"
|